use strict;
my $str = 'If he\'s restin\', I\'ll wake him up! (Shouts at the cage.) \'Ello, Mister Polly Parrot! (Owner hits the cage.) There, he moved!!!\\r\\n\\r\\nNorth Korea is accusing the U.S. government of being behind the making of the movie \\"The Interview.\\"\\r\\n\\r\\nAnd, in a dispatch on state media, the totalitarian regime warns the United States that U.S. \\"citadels\\" will be attacked, dwarfing the attack on Sony that led to the cancellation of the film\'s release.\\r\\n\\r\\nWhile steadfastly denying involvement in the hack, North Korea accused U.S. President Barack Obama of calling for \\"symmetric counteraction.\\"\\r\\n\\r\\n\\"The DPRK has already launched the toughest counteraction. Nothing is more serious miscalculation than guessing that just a single movie production company is the target of this counteraction. Our target is all the citadels of the U.S. imperialists who earned the bitterest grudge of all Koreans,\\" a report on state-run KCNA read."';
my $regex = qr/(.+?([A-Z].)\.(?:['")\\\s]?)+?\s?)/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}