#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^data:(image\/(?:jpeg|png|gif));base64,(.+)$"
Local $sString = "data:image/jpeg;base64,/9j/4AAQSkZJRgABAgEASABIAAD"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")