$re = '/^data:(image\/(?:jpeg|png|gif));base64,(.+)$/';
$str = 'data:image/jpeg;base64,/9j/4AAQSkZJRgABAgEASABIAAD';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);