re = /^data:(image\/(?:jpeg|png|gif));base64,(.+)$/
str = 'data:image/jpeg;base64,/9j/4AAQSkZJRgABAgEASABIAAD'
# Print the match result
str.match(re) do |match|
puts match.to_s
end