using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@delim(.+?)@delim";
string input = @"@delimabc@delim@delim123@delim@delim456@delim";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}