$re = '/@delim(.+?)@delim/';
$str = '@delimabc@delim@delim123@delim@delim456@delim';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);