package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^;]*; *$`)
var str = `a ; user ; name ; pass ; 123 ;
b ; login ; name ; password ; def;
c ;
d ;
e ; email ; s@d.com ; pass ; 789 ;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}