import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^;]*; *$";
final String string = "a ; user ; name ; pass ; 123 ;\n"
+ "b ; login ; name ; password ; def;\n"
+ "c ; \n"
+ "d ;\n"
+ "e ; email ; s@d.com ; pass ; 789 ;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}