$re = '/^[^;]*; *$/m';
$str = 'a ; user ; name ; pass ; 123 ;
b ; login ; name ; password ; def;
c ;
d ;
e ; email ; s@d.com ; pass ; 789 ;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);