using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?),(,|\.)?";
string substitution = @"HEY ";
string input = @"PL/SQL: Unit: ZIP_UTIL_PKG, type: PACKAGE BODY. Code Type: NATIVE. SVN: File date: $Date: 2019-08-26 10:28:11 -0500 $, Revision: $Revision: 18213 $, $Author: mark.s $.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}