const regex = /(.*?),(,|\.)?/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?),(,|\\.)?', 'mg')
const str = `PL/SQL: Unit: ZIP_UTIL_PKG, type: PACKAGE BODY. Code Type: NATIVE. SVN: File date: \$Date: 2019-08-26 10:28:11 -0500 \$, Revision: \$Revision: 18213 \$, \$Author: mark.s \$.`;
const subst = `HEY `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);