re = /(.*?),(,|\.)?/m
str = 'PL/SQL: Unit: ZIP_UTIL_PKG, type: PACKAGE BODY. Code Type: NATIVE. SVN: File date: $Date: 2019-08-26 10:28:11 -0500 $, Revision: $Revision: 18213 $, $Author: mark.s $.'
subst = 'HEY '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result