use strict;
my $str = '123?:%фывфафыывsadasdasd';
my $regex = qr~\p{Cyrillic}+~mp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";