$re = '~\p{Cyrillic}+~m';
$str = '123?:%фывфафыывsadasdasd';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;