package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<cod_prog>[1-9]\d*)\.(?<num_avv>[1-9]\d*)`)
var str = `123.456`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}