const regex = /(?<cod_prog>[1-9]\d*)\.(?<num_avv>[1-9]\d*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<cod_prog>[1-9]\\d*)\\.(?<num_avv>[1-9]\\d*)', '')
const str = `123.456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}