package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:https?://)?www\.\S+)`)
var str = `test http://www.bing.com test
test https://www.bing.com test
test www.bing.com test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}