re = /((?:https?:\/\/)?www\.\S+)/
str = 'test http://www.bing.com test
test https://www.bing.com test
test www.bing.com test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end