$re = '/((?:https?://)?www\.\S+)/';
$str = 'test http://www.bing.com test
test https://www.bing.com test
test www.bing.com test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);