import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|\\s)(?!\\b(?:basic|studio|asp|v[bs]|c\\#)\\.net)(\\w+)(?:\\.co\\.[a-z]{2}|\\.[a-z]{2,6})\\b";
final String string = "site.org asp.net dsgsvgs somedomain.com sdbbdsb vb.net otherdomain.org vs.net wax.museum somesite.net vb.net micro.co.uk sdbsdbssd asp.co.uk visualbasic.co.hk ASP.net visualstudio.co.jp ddddddd visualbasic.net visual basic.net visual studio.net uuu. www.com";
final String subst = "\\1\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}