using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\sAND)\s(?!AND\s)";
string input = @"ashfjh AND aifjipjasfpj iajiojgio jawijiowj and ajijgwijj ANDaifijs ajnfj masAND ajsfnj";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}