$re = '/(?<!\sAND)\s(?!AND\s)/';
$str = 'ashfjh AND aifjipjasfpj iajiojgio jawijiowj and ajijgwijj ANDaifijs ajnfj masAND ajsfnj';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);