re = /(?<!\sAND)\s(?!AND\s)/
str = 'ashfjh AND aifjipjasfpj iajiojgio jawijiowj and ajijgwijj ANDaifijs ajnfj masAND ajsfnj'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end