#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)([A-Z\()\h-]+):(.+?)(?=\n[A-Z\()\h-]+:|$)"
Local $sString = "AHK-VERSION:" & @CRLF & _
"AutoHotkey_L 1.1.04 or later. Tested on: Windows 7 64bit, AutoHotkey 32bit Unicode 1.1.05.01." & @CRLF & _
"" & @CRLF & _
"AUTHOR:" & @CRLF & _
"?A_Samurai?" & @CRLF & _
"" & @CRLF & _
"DATE:" & @CRLF & _
"?2011?" & @CRLF & _
"" & @CRLF & _
"DEPENDENCIES:" & @CRLF & _
"none" & @CRLF & _
"" & @CRLF & _
"KEYWORDS:" & @CRLF & _
"gui, activeX, html" & @CRLF & _
"" & @CRLF & _
"LICENSE:" & @CRLF & _
"Public Domain" & @CRLF & _
"" & @CRLF & _
"LINK:" & @CRLF & _
"---" & @CRLF & _
"" & @CRLF & _
"PARAMETER(S):" & @CRLF & _
"Text : the text strings to display in the edit box." & @CRLF & _
"Title : the title for the GUI window." & @CRLF & _
"Timeout : if specified, the edit box will disappear in the given seconds." & @CRLF & _
"Permanent : if this is TRUE, closing the window does not destroy the window but hide it." & @CRLF & _
"So it can be displayed again with the window handle." & @CRLF & _
"GUIOptions : the options for the Edit box GUI window." & @CRLF & _
"ControlOptions : the options for the Edit control." & @CRLF & _
"Margin : the margin in pixels between the window borders and the control." & @CRLF & _
"" & @CRLF & _
"REMARK(S):" & @CRLF & _
"No global variables are used. However, it uses these label names: EditBoxClose, EditBoxEscape" & @CRLF & _
"EditBoxResize. So the script should avoid using the label names." & @CRLF & _
"" & @CRLF & _
"RETURN VALUE:" & @CRLF & _
"The window handle (hwnd) of the created GUI window" & @CRLF & _
"" & @CRLF & _
"SYNTAX:" & @CRLF & _
"EditBox(Text, Title="", Timeout=0, Permanent=False, GUIOptions="Resize MaximizeBox Minsize420x320", ControlOptions="VScroll W400 H300", Margin=10)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")