import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)([A-Z\\()\\h-]+):(.+?)(?=\\n[A-Z\\()\\h-]+:|$)";
final String string = "AHK-VERSION:\n"
+ "AutoHotkey_L 1.1.04 or later. Tested on: Windows 7 64bit, AutoHotkey 32bit Unicode 1.1.05.01.\n\n"
+ "AUTHOR:\n"
+ "?A_Samurai?\n\n"
+ "DATE:\n"
+ "?2011?\n\n"
+ "DEPENDENCIES:\n"
+ "none\n\n"
+ "KEYWORDS:\n"
+ "gui, activeX, html\n\n"
+ "LICENSE:\n"
+ "Public Domain\n\n"
+ "LINK:\n"
+ "---\n\n"
+ "PARAMETER(S):\n"
+ "Text : the text strings to display in the edit box.\n"
+ "Title : the title for the GUI window.\n"
+ "Timeout : if specified, the edit box will disappear in the given seconds.\n"
+ "Permanent : if this is TRUE, closing the window does not destroy the window but hide it.\n"
+ "So it can be displayed again with the window handle.\n"
+ "GUIOptions : the options for the Edit box GUI window.\n"
+ "ControlOptions : the options for the Edit control.\n"
+ "Margin : the margin in pixels between the window borders and the control.\n\n"
+ "REMARK(S):\n"
+ "No global variables are used. However, it uses these label names: EditBoxClose, EditBoxEscape\n"
+ "EditBoxResize. So the script should avoid using the label names.\n\n"
+ "RETURN VALUE:\n"
+ "The window handle (hwnd) of the created GUI window\n\n"
+ "SYNTAX:\n"
+ "EditBox(Text, Title=\"\", Timeout=0, Permanent=False, GUIOptions=\"Resize MaximizeBox Minsize420x320\", ControlOptions=\"VScroll W400 H300\", Margin=10)\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}