use strict;
my $str = 'AHK-VERSION:
AutoHotkey_L 1.1.04 or later. Tested on: Windows 7 64bit, AutoHotkey 32bit Unicode 1.1.05.01.
AUTHOR:
?A_Samurai?
DATE:
?2011?
DEPENDENCIES:
none
KEYWORDS:
gui, activeX, html
LICENSE:
Public Domain
LINK:
---
PARAMETER(S):
Text : the text strings to display in the edit box.
Title : the title for the GUI window.
Timeout : if specified, the edit box will disappear in the given seconds.
Permanent : if this is TRUE, closing the window does not destroy the window but hide it.
So it can be displayed again with the window handle.
GUIOptions : the options for the Edit box GUI window.
ControlOptions : the options for the Edit control.
Margin : the margin in pixels between the window borders and the control.
REMARK(S):
No global variables are used. However, it uses these label names: EditBoxClose, EditBoxEscape
EditBoxResize. So the script should avoid using the label names.
RETURN VALUE:
The window handle (hwnd) of the created GUI window
SYNTAX:
EditBox(Text, Title="", Timeout=0, Permanent=False, GUIOptions="Resize MaximizeBox Minsize420x320", ControlOptions="VScroll W400 H300", Margin=10)
';
my $regex = qr/(?s)([A-Z\()\h-]+):(.+?)(?=\n[A-Z\()\h-]+:|$)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}