package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<\/?a.*?>`)
var str = `<a href="/GPWIS2/pl/emitents/news/4FUNMEDIA,PL4FNMD00013,1,current,1,1;jsessionid=vD8S3MVOLWcx-Cg2ecHBojDy.undefined">4Fun Media SA</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}