using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=key\s)\d+(?:\s*(?:,|and)\s*\d+)*";
string input = @"some text key 1, 2, 3 ,4 and 5. some other text dog 6, 7, 8, 9 and 10. some text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}