const regex = /(?<=key\s)\d+(?:\s*(?:,|and)\s*\d+)*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=key\\s)\\d+(?:\\s*(?:,|and)\\s*\\d+)*', 'gm')
const str = `some text key 1, 2, 3 ,4 and 5. some other text dog 6, 7, 8, 9 and 10. some text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}