$re = '/(?<=key\s)\d+(?:\s*(?:,|and)\s*\d+)*/m';
$str = 'some text key 1, 2, 3 ,4 and 5. some other text dog 6, 7, 8, 9 and 10. some text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);