#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(<img.*src=)["']https:\/\/(.*)["']"
Local $sString = "<p><img class="alignnone wp-image-36109 size-full" src="https://onhax.net/wp-content/uploads/2014/10/WjhzQlNRaDJrYUUx_o_using-freedom-for-unlimited-in-app-purchases-android-.jpg" alt="WjhzQlNRaDJrYUUx_o_using-freedom-for-unlimited-in-app-purchases-android-" width="480" height="360"/></p>" & @CRLF & _
"<img class="alignnone size-full wp-image-126019" src="https://i0.wp.com/onhax.net/wp-content/uploads/2016/03/sd.png?resize=300%2C300" alt="" data-recalc-dims="1"/>" & @CRLF & _
"<img class="alignnone size-full wp-image-126019" src="https://onhax.net/wp-content/uploads/2016/03/sd.png?resize=300%2C300" alt="" data-recalc-dims="1"/>"
Local $sSubst = "\1"http://example.com/\2""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)