# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<img.*src=)[\"']https:\/\/(.*)[\"']"
test_str = ("<p><img class=\"alignnone wp-image-36109 size-full\" src=\"https://onhax.net/wp-content/uploads/2014/10/WjhzQlNRaDJrYUUx_o_using-freedom-for-unlimited-in-app-purchases-android-.jpg\" alt=\"WjhzQlNRaDJrYUUx_o_using-freedom-for-unlimited-in-app-purchases-android-\" width=\"480\" height=\"360\"/></p>\n"
"<img class=\"alignnone size-full wp-image-126019\" src=\"https://i0.wp.com/onhax.net/wp-content/uploads/2016/03/sd.png?resize=300%2C300\" alt=\"\" data-recalc-dims=\"1\"/>\n"
"<img class=\"alignnone size-full wp-image-126019\" src=\"https://onhax.net/wp-content/uploads/2016/03/sd.png?resize=300%2C300\" alt=\"\" data-recalc-dims=\"1\"/>")
subst = "\\1\"http://example.com/\\2\""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.