#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x) (?:" & @CRLF & _
" <" & @CRLF & _
" (?: p | li )" & @CRLF & _
" \b" & @CRLF & _
" [^>]*? color \s* : \s* " & @CRLF & _
" (?:" & @CRLF & _
" ( black ) # (1)" & @CRLF & _
" | transparent" & @CRLF & _
" )" & @CRLF & _
" [^>]*? >" & @CRLF & _
" (?(1)" & @CRLF & _
" (?: \s* <span \b [^>]*? > )?" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" <span \b" & @CRLF & _
" [^>]*? color \s* : \s* black [^>]*? >" & @CRLF & _
" )" & @CRLF & _
" (?s)" & @CRLF & _
" \s* <code \b" & @CRLF & _
" (?: ".*?" | '.*?' | [^>]*? )+ >" & @CRLF & _
"" & @CRLF & _
" (*SKIP) (*FAIL) " & @CRLF & _
" | " & @CRLF & _
" <code \b" & @CRLF & _
" [^>]*? style [^>]*? background-color \s* : \s* transparent [^>]*? >"
Local $sString = "<p....color: black...> <span.......>" & @CRLF & _
"<code style="background-color: transparent;">" & @CRLF & _
"" & @CRLF & _
"<p....color: black...>" & @CRLF & _
"<code style="background-color: transparent;">" & @CRLF & _
"" & @CRLF & _
"<p....color: transparent...>" & @CRLF & _
"<code style="background-color: transparent;">" & @CRLF & _
"" & @CRLF & _
"<span....color: black...>" & @CRLF & _
"<code style="background-color: transparent;">" & @CRLF & _
"" & @CRLF & _
"<li style....color: black...> <span....color: black...>" & @CRLF & _
"<code style="background-color: transparent;">" & @CRLF & _
"" & @CRLF & _
"<li style....color: black...>" & @CRLF & _
"<code>" & @CRLF & _
"" & @CRLF & _
"<li style....color: black...> <span......>" & @CRLF & _
"<code style="background-color: transparent;">" & @CRLF & _
"" & @CRLF & _
"<code style="background-color: transparent;">" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")