const regex = new RegExp(' (?:
<
(?: p | li )
\\b
[^>]*? color \\s* : \\s*
(?:
( black ) # (1)
| transparent
)
[^>]*? >
(?(1)
(?: \\s* <span \\b [^>]*? > )?
)
|
<span \\b
[^>]*? color \\s* : \\s* black [^>]*? >
)
(?s)
\\s* <code \\b
(?: ".*?" | \\'.*?\\' | [^>]*? )+ >
(*SKIP) (*FAIL)
|
<code \\b
[^>]*? style [^>]*? background-color \\s* : \\s* transparent [^>]*? >', 'g')
const str = `<p....color: black...> <span.......>
<code style="background-color: transparent;">
<p....color: black...>
<code style="background-color: transparent;">
<p....color: transparent...>
<code style="background-color: transparent;">
<span....color: black...>
<code style="background-color: transparent;">
<li style....color: black...> <span....color: black...>
<code style="background-color: transparent;">
<li style....color: black...>
<code>
<li style....color: black...> <span......>
<code style="background-color: transparent;">
<code style="background-color: transparent;">
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}