import Foundation
let pattern = ##"""
(?:
<
(?: p | li )
\b
[^>]*? color \s* : \s*
(?:
( black ) # (1)
| transparent
)
[^>]*? >
(?(1)
(?: \s* <span \b [^>]*? > )?
)
|
<span \b
[^>]*? color \s* : \s* black [^>]*? >
)
(?s)
\s* <code \b
(?: ".*?" | '.*?' | [^>]*? )+ >
(*SKIP) (*FAIL)
|
<code \b
[^>]*? style [^>]*? background-color \s* : \s* transparent [^>]*? >
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"""
<p....color: black...> <span.......>
<code style="background-color: transparent;">
<p....color: black...>
<code style="background-color: transparent;">
<p....color: transparent...>
<code style="background-color: transparent;">
<span....color: black...>
<code style="background-color: transparent;">
<li style....color: black...> <span....color: black...>
<code style="background-color: transparent;">
<li style....color: black...>
<code>
<li style....color: black...> <span......>
<code style="background-color: transparent;">
<code style="background-color: transparent;">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)