#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^-.]+([-.])(?:[^-.]+\1){3}[^-.]+$"
Local $sString = "9-8-7" & @CRLF & _
"1.2.3.4-5" & @CRLF & _
"1.2.3.4.5" & @CRLF & _
"AB-CD-EF-GH-IJ" & @CRLF & _
"1-2-3-4-5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")