re = /^[^-.]+([-.])(?:[^-.]+\1){3}[^-.]+$/m
str = '9-8-7
1.2.3.4-5
1.2.3.4.5
AB-CD-EF-GH-IJ
1-2-3-4-5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end