$re = '/^[^-.]+([-.])(?:[^-.]+\1){3}[^-.]+$/m';
$str = '9-8-7
1.2.3.4-5
1.2.3.4.5
AB-CD-EF-GH-IJ
1-2-3-4-5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);