import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[([\\w\\s*:/\\-\\.]*)\\]\\(([^()]+)\\)";
final String string = "\n\n"
+ "Let's see for example the [Diaspora*\n"
+ "project](https://diasporafoundation.org/), a decentralized social network. The\n"
+ "project is an alternative to Facebook and Twitter by promising Liberty,\n"
+ "Privacy and Decentralization. This last word is the key problem. This kind of\n"
+ "project finds its interests by multiplying what is called \"pods\" (servers with\n"
+ "the software installed). However, in this case the installation process is\n"
+ "very complicated, so even those who are comfortable with computers are not\n"
+ "inclined to make the effort to install their own pod. See for example the\n"
+ "[installation process for Ubuntu\n"
+ "Trusty](https://wiki.diasporafoundation.org/Installation/Ubuntu/Trusty). The\n"
+ "project offers a Vagrant installation too, but the documentation only admits\n"
+ "that you know what you do, that you are a developer. If it is difficult to\n\n"
+ "\n\n"
+ "_A pretty decentralized network (Source: <https://diasporafoundation.org/>)_\n\n\n\n"
+ "Diaspora* is not the only project facing this problem. We can add\n"
+ "[MediaGoblin](http://www.mediagoblin.org/pages/tour.html) to the list, an\n"
+ "alternative to YouTube allowing you to host media (and [here it's deployment\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}