# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[([\w\s*:/\-\.]*)\]\(([^()]+)\)"
test_str = ("\n\n"
"Let's see for example the [Diaspora*\n"
"project](https://diasporafoundation.org/), a decentralized social network. The\n"
"project is an alternative to Facebook and Twitter by promising Liberty,\n"
"Privacy and Decentralization. This last word is the key problem. This kind of\n"
"project finds its interests by multiplying what is called \"pods\" (servers with\n"
"the software installed). However, in this case the installation process is\n"
"very complicated, so even those who are comfortable with computers are not\n"
"inclined to make the effort to install their own pod. See for example the\n"
"[installation process for Ubuntu\n"
"Trusty](https://wiki.diasporafoundation.org/Installation/Ubuntu/Trusty). The\n"
"project offers a Vagrant installation too, but the documentation only admits\n"
"that you know what you do, that you are a developer. If it is difficult to\n\n"
"\n\n"
"_A pretty decentralized network (Source: <https://diasporafoundation.org/>)_\n\n\n\n"
"Diaspora* is not the only project facing this problem. We can add\n"
"[MediaGoblin](http://www.mediagoblin.org/pages/tour.html) to the list, an\n"
"alternative to YouTube allowing you to host media (and [here it's deployment\n\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.