$re = '/\[([\w\s*:/\-\.]*)\]\(([^()]+)\)/';
$str = '
Let\'s see for example the [Diaspora*
project](https://diasporafoundation.org/), a decentralized social network. The
project is an alternative to Facebook and Twitter by promising Liberty,
Privacy and Decentralization. This last word is the key problem. This kind of
project finds its interests by multiplying what is called "pods" (servers with
the software installed). However, in this case the installation process is
very complicated, so even those who are comfortable with computers are not
inclined to make the effort to install their own pod. See for example the
[installation process for Ubuntu
Trusty](https://wiki.diasporafoundation.org/Installation/Ubuntu/Trusty). The
project offers a Vagrant installation too, but the documentation only admits
that you know what you do, that you are a developer. If it is difficult to

_A pretty decentralized network (Source: <https://diasporafoundation.org/>)_
Diaspora* is not the only project facing this problem. We can add
[MediaGoblin](http://www.mediagoblin.org/pages/tour.html) to the list, an
alternative to YouTube allowing you to host media (and [here it\'s deployment
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);