#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^(\d+:\d+) (.+?)$(?=(?:\s^\d+:\d+)|\z)"
Local $sString = "1:1 Bob drives his car." & @CRLF & _
"1:2 Bob and his wife are going on a trip. " & @CRLF & _
"They will have an awesome time on the beach." & @CRLF & _
"1:3 this is a long line" & @CRLF & _
"what is this" & @CRLF & _
"more lines" & @CRLF & _
"1:4 blah" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")