import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+:\\d+) (.+?)$(?=(?:\\s^\\d+:\\d+)|\\z)";
final String string = "1:1 Bob drives his car.\n"
+ "1:2 Bob and his wife are going on a trip. \n"
+ "They will have an awesome time on the beach.\n"
+ "1:3 this is a long line\n"
+ "what is this\n"
+ "more lines\n"
+ "1:4 blah\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}