$re = '/^(\d+:\d+) (.+?)$(?=(?:\s^\d+:\d+)|\z)/ms';
$str = '1:1 Bob drives his car.
1:2 Bob and his wife are going on a trip.
They will have an awesome time on the beach.
1:3 this is a long line
what is this
more lines
1:4 blah
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);