use strict;
my $str = '/myns:Node1/myns:Node2[./myns:Node3=123456]/myns:Node4';
my $regex = qr/\/(?![^\[]*\])/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";