import Foundation
let pattern = #"\/(?![^\[]*\])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"/myns:Node1/myns:Node2[./myns:Node3=123456]/myns:Node4"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)