$re = '/\/(?![^\[]*\])/';
$str = '/myns:Node1/myns:Node2[./myns:Node3=123456]/myns:Node4';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;