#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?:(\+[0-9]{1,3})[ -])?\(?\d{3}\)?[- ]?\d{3}[- ]?\d{4}"
Local $sString = "1234567890" & @CRLF & _
"123-456-7890" & @CRLF & _
"(123)456-7890" & @CRLF & _
"123 456 7890" & @CRLF & _
"+1 123 456 7890" & @CRLF & _
"+123 123 456 7890" & @CRLF & _
"+1234 123 456 7890" & @CRLF & _
"+23 (123) 456-7890" & @CRLF & _
"+23 (123) 123-456-7890"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")