using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=newProductsInfo: .*?)\[\d+].*?(?=,\[\d+]|$)";
string input = @"newProductsInfo: [[1] - $2 dollars,[2] New Product,[3] Hello,[4]Same, [5]Value]
newProductsInfo: [[1] - $2 dollars,[4]Same, [5]Value],[2] New Product,[3] Hello,[4]Same, [5]Value]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}