const regex = /(?<=newProductsInfo: .*?)\[\d+].*?(?=,\[\d+]|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=newProductsInfo: .*?)\\[\\d+].*?(?=,\\[\\d+]|$)', 'gm')
const str = `newProductsInfo: [[1] - \$2 dollars,[2] New Product,[3] Hello,[4]Same, [5]Value]
newProductsInfo: [[1] - \$2 dollars,[4]Same, [5]Value],[2] New Product,[3] Hello,[4]Same, [5]Value]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}